ASUS RT N16 e DD-WRT: Un router SUPER!

7 04 2012
Premessa

Ho da poco acquistato un ASUS RT N16, porte USB, 4 LAN, wifi n … non potevo non sbrasarlo!
Visto che lo userò per casa ho scelto come distro DD-WRT, sia per la faciltà d’uso che per i molteplici pacchetti opzionali già disponibili online.

Come prima cosa procediamo col preparare una memoria di massa per la nostra piccola LinuxBox.

Optware

Per maggiori dettagli su Optware vi rimando qui

Iniziamo col preparare il nostro disco USB (maggiori dettagli) creando le partizioni Linux adeguate.
Inseriamo il nostro disco USB in un PC Linux. Dopo che il S.O. l’avrà riconosciuto verifichiamo il nome del device (nel nostro esempio sarà /dev/sdb) e smontiamolo.
Seguiamo la procedura seguente, da shell:

root@Linux:/fdisk /dev/sdb
Command (m for help): d
Selected partition 1
Command (m for help): p
Disk /dev/sdd: 
[...]
Command (m for help): p
[...]
Command (m for help): n
Command action
  e   extended
  p   primary partition (1-4)
p
Partition number (1-4): 1
First cylinder (1-621, default 1):<ENTER>
Using default value 1
Last cylinder or +size or +sizeM or +sizeK (1-621, default 621): +512M <ENTER>
Command (m for help): n
Command action
  e   extended
  p   primary partition (1-4)
p
Partition number (1-4): 2
First cylinder (197-621, default 197):<ENTER>
Using default value 197
Last cylinder or +size or +sizeM or +sizeK (197-621, default 621): +64M <ENTER>
Command (m for help): n
Command action
  e   extended
  p   primary partition (1-4)
p
Partition number (1-4): 3
First cylinder (197-621, default 197):<ENTER>
Using default value 621
Last cylinder or +size or +sizeM or +sizeK (197-621, default 621): +128M <ENTER>
Command (m for help): n
Command action
  e   extended
  p   primary partition (1-4)
p
Partition number (1-4): 4
First cylinder (197-621, default 197):<ENTER>
Using default value 1
Last cylinder or +size or +sizeM or +sizeK (197-621, default 621): <ENTER>
Command (m for help): t
Partition number (1-4): 2
Hex code (type L to list codes): 82
Changed system type of partition 2 to 82 (Linux swap)
Command (m for help): p
[...]
Command (m for help): w

Infine lanciamo:

mke2fs -m 1 -L Optware /dev/sdb1
mke2fs -m 1 -L Shared /dev/sdb3
mke2fs -m 1 -L Data /dev/sdb4
mkswap /dev/sdb2

USB DRIVE PRONTO!! 🙂

Scarichiamo DD-WRT per il nostro router.
Colleghiamoci all’area download  e cerchiamo l’ultima versione disponibile del firmware.

Io ho provato il tutto con la release svn16758.

Andiamo in

Downloads › others › eko › V24-K26 › svn<xyz>
e scarichiamo il file mini.trx

Apriamo il nostro Router ASUS RT-N16 di pacca e colleghiamoci su una delle porte LAN
Apriamo ‘Internet Explorer’ (SI proprio IE!! – questo è il browser raccomandato!) ed andiamo nella schermata del firmware upgrade.


Da qui carichiamo il file mini ed attendiamo l’upgrade.
Una volta terminato possiamo accedere al router ed inserire le nostre credenziali preferite (ad es: root – pass, ma anche admin – admin se siete coraggiosi!)

Questa versione contiene moltissime funzionalità evolute, ma per godere del vero salto di qualità dovremo passare alla MEGA di DD-wrt.

Scarichiamo il file della stessa release della mini (nel mio caso 16758)
ed installiamolo usando l’interfaccia web di DD
Administration->Firmware Upgrade
Settiamo
After flashing, reset to: Reset
to Default Settings
e ri-accediamo al router sulla classica 192.168.1.1 da webif
Questa versione GRANDE ci permette di fare molte +cose e ci da accesso a funzionalità avanzate. Tra queste troviamo quella di nostro interesse. L’accesso ai servizi USB del router (opzione assente nella ver. mini)

Rendiamo accessibile il disco USB realizzato in precedenza.
Dalla web GUI
Services->USB
abilitiamo: Core USB
support USB 2.0
support USB storage
support Printer Support (optional)
ext2/ext3 File System support – solo per le versioni precedenti alla SVN 15501
FAT File system support solo per le versioni precedenti alla SVN 15501
Automatic Drive Mount
Selezioniamo mount ad /opt dal menu a tendina
Salviamo ed applichiamo le modifiche.
Riavviato il router bisogna farlo uscire su Internet.
Quindi disabilitiamo il Firewall di DDWTR
Andiamo all GUI Web Security->Firewall->SPI Firewall disable
torniamo da shell e lanciamo un ping per vedere se usciamo
Se tutto OK possiamo scaricare optware

wget -O /tmp/prep_optware http://wd.mirmana.com/prep_optware
sh /tmp/prep_optware

ora l’installer inizierà a fare un pò di spesa sul WEB.
Andiamo a farci un caffè e al nostro ritorno troveremo tutto pronto.
Possiamo riavviare il router ed assicurarci che il driver sia montato correttamente, come indicato nell’immagine sotto.

Per dare uno sguardo a cosa abbiamo creato basta fare
service

Troveremo tutti i servizi da utilizzare subito, tra cui Samba, Asterisk, Transmission (un client torrent) …

BUON DIVERTIMENTO!





Buon Compleanno Pinguino!

8 04 2011

Un evoluzione che dura 20 anni. Dalla prima mail di Linus Torvalds, a Stallman, fino agli investimenti di IBM. Con una simpatica animazione (un pò in stile Google) riviviamo i 20 anni Linux, un’idea più che un S.O. che oggi si trova un pò da per tutto, dai cellulari, fino ai televisori.

Fate un salto sul sito della linux foundation per dare uno sguardo a come si festeggierà il primo ventennale di quel Hello everybody out there da cui tutto ha preso inizio.






Monitoring con Nagios: installazione

24 11 2010

Nagios

In questa serie di articoli mi dedicherò alla realizzazione di un server di Monitoring di rete tramite l’ottimo Nagios.

I test sono stati effettuati con Fedora Core 13, Nagios 3.2.3, e nagios-plugins 1.4.15.

Preparazione

Iniziamo ad installare tutti pacchetti necessari:

yum install httpd gcc glibc glibc-common gd gd-devel

Creiamo un nuovo utente nagios

useradd -m nagios
passwd nagios

ed un nuovo gruppo nagcmd

groupadd nagcmd
usermod -a -G nagcmd nagios
usermod -a -G nagcmd apache

e scarichiamo le ultime versioni di nagios e nagios-plugins

wget http://downloads.sourceforge.net/project/nagios/nagios-3.x/nagios-3.2.3/nagios-3.2.3.tar.gz
wget http://downloads.sourceforge.net/project/nagiosplug/nagiosplug/1.4.15/nagios-plugins-1.4.15.tar.gz

Installazione

Scompattiamo l’archivio e compiliamo

tar zxvf nagios-3.2.3.tar.gz
cd nagios-3.2.3
./configure --with-command-group=nagcmd
make all
make install
make install-init
make install-config
make install-commandmode
make install-webconf

Creiamo ora un account amministratore per il loggin della Nagios web interface.

htpasswd -c /usr/local/nagios/etc/htpasswd.users nagiosadmin

Riavviamo Apache

service httpd restart

Passiamo ora ai Nagios Plugins

cd ..
tar xzf nagios-plugins-1.4.15.tar.gz
cd nagios-plugins-1.4.15
./configure --with-nagios-user=nagios --with-nagios-group=nagcmd
make
make install

Primo avvio del sistema

Aggiungiamo Nagios alla lista dei servizi che partono in automatico al boot

chkconfig --add nagios
chkconfig nagios on

Verifichiamo a questo puto che tutto sia ok tramite un test sul file di configurazione di Nagios:

/usr/local/nagios/bin/nagios -v /usr/local/nagios/etc/nagios.cfg

dovremo trovarci una cosa del tipo

Total Warnings: 0
Total Errors:   0
Things look okay - No serious problems were detected during the pre-flight check

A questo punto possiamo avviare il processo

service nagios start

N.B.: conviene disabilitare SElinux

vi /etc/selinux/config

ed impostare

SELINUX=disabled




Update OpenWrt

7 11 2010

Mi è capitato di voler passare da un Kamikaze 7.09 ad una versione più aggiornata di OpenWRT.

Pensavo di dover rifare la solita e tediosa procedura di debrick e invece… niente di più semplice!
Basta scaricare la versione .trx del firmware da qui

aprire l’interfaccia WebIF di Kamikaze

andare in System->Settings->Upgrade

caricare il file e lanciare l’update

Dopo qualche minuto avrete la nuova fiammante versione di Kamikaze 8.09.2 (in questo caso) pronta a rispondervi sul telnet dall’ IP 192.168.1.1

 





Fonera e Asterisk: installazione

23 08 2010

Anche la piccola Fonera può diventare un centralino grazie ad Asterisk.

La ricetta è molto semplice: prendiamo una fonera, ci carichiamo facilmente openwrt (testato con Kamikaze 8.09.2) con ap51 (come indicato qui) e andiamo di opkg.

opkg update
root@OpenWrt:~# opkg list|grep asterisk

troveremo qualcosa del tipo

asterisk14 - 1.4.23.1-1.2 - Asterisk is a complete PBX in software. It  provides all of the features

Passiamo all’installazione vera e propria con

root@OpenWrt:~# opkg install asterisk14

Pazientare un bel pò…

E godersi il risultato:

root@OpenWrt:~# asterisk -vvvcgd

Da notare l’occupazione di spazio

PRIMA

root@OpenWrt:~# df -h
Filesystem                Size      Used Available Use% Mounted on
rootfs                    1.5M      1.5M         0 100% /
/dev/root                 1.5M      1.5M         0 100% /rom
tmpfs                     6.7M    760.0k      5.9M  11% /tmp
tmpfs                   512.0k         0    512.0k   0% /dev
/dev/mtdblock2            5.4M      1.2M      4.2M  22% /jffs
mini_fo:/jffs             1.5M      1.5M         0 100% /

DOPO

root@OpenWrt:~# df -h
Filesystem                Size      Used Available Use% Mounted on
rootfs                    1.5M      1.5M         0 100% /
/dev/root                 1.5M      1.5M         0 100% /rom
tmpfs                     6.7M    760.0k      5.9M  11% /tmp
tmpfs                   512.0k         0    512.0k   0% /dev
/dev/mtdblock2            5.4M      3.2M      2.2M  59% /jffs
mini_fo:/jffs             1.5M      1.5M         0 100% /

Niente male…





eGroupWare: installazione

31 05 2010

Prerequisiti

in questo articolo ci riferiremo ad una piattaforma Fedora Core 8 (su cui ho fatto i test) e su cui è già presente MySQL ed un server mail (nel mio caso sendmail+dovecot) già installato e funzionante.

eGroupWare funziona comunque su ogni altra distribuzione, ma richiede sempre l’esistenza di un mail server.

Iniziamo

Sul sito del progetto è disponibile tutto il materiale di cui abbiamo bisogno, ed anche una demo per verificare on-line da subito le potenzialità del prodotto, senza installare nulla.

Procuriamoci i file relativi all’ultima release stabile 1.6

eGroupware-1.6.003-2.tar.gz
eGroupware-egw-pear-1.6.003-2.tar.gz
eGroupware-mydms-1.6.003-2.tar.gz

copiamoli  e scompattiamoli nella home directory di apache sul nostro server mail, nel mio caso ho creato una cartella apposita egroupware (/var/www/html/egroupware)

Installiamo i pacchetti PHP

yum install php-pear php5-imap php5-ldap php-gd

Controlliamo che nel file /etc/php.ini siano impostati i seguenti valori

display_errors=Off
memory_limit = 32M
file_upload = On
mbstring.func_overload = 7

e puntiamo il browser su  http://127.0.0.1/egroupware/setup per iniziare la configurazione.

Qui troverete due login

  1. Setup/Config Admin Login
  2. Header Admin Login

1. Loggandosi a questo menu dovremo riuscire a rendere tutti i flags verdi. Solo in questo modo avremo una corretta configurazione, in particolare gli aspetti di primo interesse sono legati al Passaggio 2 – Configurazione. Qui troveremo i dettagli sul server mail, che sarà necessario configurare adeguatamente e sempre in questo menu dovrete sceglierete l’autenticazione tra mail e LDAP (io ho testato la prima) con cui accedere all’interfaccia web del sistema.

egroupware setup

2. Qui invece troverete una sezione dedicata agli header dove sono presenti configurazioni (solitamente quelle di dafault vanno bene) sulla root del sito, sul DB e sulle password di accesso.

egroupware header

Superata questa fase, per altro abbastanza intuitiva, potrete accedere all’interfaccia del vostro groupware.

Riferimenti

http://wiki.contribs.org/Egroupware
http://blogs.techrepublic.com.com/opensource/?p=944




Openwrt sulla Fonera: 5 minuti e 1 caffè

12 05 2010
La Fonera plus

La Mia Fonera+

Grazie alla comunità di Freifunk oggi trasformare una fonera in un router OpenWrt è veramente un gioco da ragazzi.

Freifunk (dal tedesco “Radio Libera” – radio inteso come canale radio) è una delle prime community che hanno sposato la causa delle reti libere senza fili per divulgare il collegamento, la comunicazione e ridurre il digital divide (ma anche in italia ne abbiamo

di belle) e , per rendere le cose semplici, i ragazzi di questa community hanno prodotto un software-ino capace di flashre autonomamente la fonera per renderla un nodo della loro rete wifi.

FreiFunk AP51

La versione Win di AP51

Ho facilmente usato questo AP51 (così si chiama il sw in questione) per mettere OpenWrt 8.09 sulla mia piccola Fonera+ in 3 passi.

Download :

scarichiamo il sw di freifunk  ap51-flash-fonera-gui-1.0-42.exe (ho usato la ver. win ma ce ne sono anche x linux)

scarichiamo openwrt-atheros-root.squashfs e openwrt-atheros-vmlinux.lzma da qui

Esecuzione:

Colleghiamo la Fonera al PC e lanciamo l’eseguibile specificando i campi

OpenWrt Rootfs – Use external file -> openwrt-atheros-root.squashfs

Kernel – Use external file -> openwrt-atheros-vmlinux.lzma

Selezioniamo l’interfaccia di rete a cui è collegata la fonera

Accendiamo la Fonera e GO!

Caffè:

Visto che ci vorrà un bel pò di tempo prepariamoci  un bel caffè, al nostro ritorno il nostro routerino OpenWrt sarà pronto!





Fonera e Domotica

24 04 2010

Magari l’ho scoperto tardi, ma questo vale certamente la pena di nominarlo…
Chi lo dice che con la fonera si può solo navigare, su questo sito ci sono alcuni esperimenti veramente interessanti su come utilizzare la fonera per applicazioni di telecontrollo.





eGroupWare: di cosa si tratta

14 04 2010

eGroupWare è un software open source per il lavoro collaborativo (groupware appunto) realizzato per sposare le necessità aziendali, dalle PMI alle realtà enterprise.

Nessun uomo è un isola…

Qualcuno si affannava, già tempo addietro, a sostenere che l’uomo è una componente integrante dell’umanità, una parte di un tutto. Questo concetto assume oggi, nell’era della comunicazione e del Web 2.0 un significato tuttaltro che meramente filosofico. Se pensiamo che oggi i mezzi di comunicazione alla portata dell’utente comune tendono sempre più  all’interazione, alla collaborazione ed al allways on è chiaro come, in un ambiente come quello lavorativo, queste esigenze diventano spesso delle reali necessità.

Se proprio la nostra vita è lavoro e se per farlo, come quasi sempre accade, abbiamo bisogno di interagire con colleghi, clienti, fornitori, e quante altre entità ruotino intorno a questo microcosmo che ci occupa le giornate, allora tanto vale farlo in modo più dinamico e sopratutto al passo con i tempi.

Abbandoniamo quindi l’idea di tutte le scartoffie che girano in un ufficio… anzi immaginiamo di raccoglierle tutte.

La fedele agenda, il calendario su cui annotare gli appuntamenti, i block notes pieni di progetti e planning aziendali, i post-it, i messaggini lasciati sulle scrivanie dei colleghi assenti, la posta, i documenti da consegnare/ricevere/far firmare dal capo/collega/cliente in papuasia…

Bene prendiamo tutta sta roba e pensiamo di renderla digitale, comune, accessibile da chi vogliamo noi e da nessun altro, modificabile, ricercabile facilmente ed integrata con i sistemi digitali che comunemente usiamo (internet e posta elettronica). Il tutto accessibile da qualunque parte del mondo, senza bisogno di imprecare, come quella volta che abbiamo scordato l’agenda in ufficio e ci sono volute 2 ore per recupere quel numero di telefono…

Qui basta una connessione ad internet… e se non avete neanche quella, beh meglio rimanere a casa, anzi in caverna!

Un pò di tecnicismi

Finito di dare sfogo alle mie velleità da scrittore e terminata la fuffa veniamo a cose un pò più tecniche

eGroupWare (da ora in avanti egw)  è un’applicazione estremamente flessibile ed oggi anche completa e matura. Può essere vista come un framework, una piattaforma CRM,  un modo per stare a contatto con il gruppo di lavoro, indipendentemente da dove ci si trova e con quale strumento ci si accede. Infatti egw è  platform-independent e  permette l’interazione con diversi groupware clients, quali  Kontact, Novell Evolution, o Microsoft Outlook e può essere usato tramite terminali mobili o PDA.

L’unico requisito è quello di fare uso di una piattaforma X-AMP. Nel nostro caso, ovviamente parleremo di LAMP.

Egw si compone di diversi elementi/applicazioni, fra cui:

  • Calendario
  • Gestore di contatti
  • Client di posta
  • File manager
  • Site manager
  • Applicazioni per il  project manager
  • Wiki
  • Sistema di condivisione della conoscenza (molto in voga nelle P.A.)

In questa serie di articoli (spero di farcela) vedremo alcune di queste funzionalità, partendo dall’installazione del sistema su un server Linux





OpenWrt su Linksys WRT54G: Universal Repeater

29 09 2009

Quante volte vi siete trovati a girare per casa in cerca del vostro segnale wifi?
Quante volte avreste desiderato abbattere quella maledetta parete di tufo/pietra ottocentesca di casa vostra che riduce drasticamente le probabilità di navigare in wireless per tutta la casa?
Quante volte avete desiderato espandere il vostro wifi oltre i confini delle striminzite antennine del vostro Alice Gate di Telecozz?
Bene ora potete!

Universal Repeater

Bene, tralasciando questa ridicola introduzione e venendo al dunque ho ottenuto un comodo ripetitore di segnale configurando il mio WRT54GL con pochi passaggi.
La situazione in cui ci troviamo è tipo quella riportata in figura.

Ampliare la rete wifi con un repeater

Ampliare la rete wifi con un repeater

Per prima cosa è necessario (se si vuole utilizzare la WPA-PSK impostata di default da Telecom) scaricare i seguenti pacchetti direttamente su OpenWrt.

root@OpenWrt:~# ipkg install wpa-supplicant
root@OpenWrt:~# ipkg install hostapd
root@OpenWrt:~# ipkg install zlib
root@OpenWrt:~# ipkg install libopenssl

Per poter visionare cosa avete sul sistema usate questo

root@OpenWrt:~# ipkg list_installed
base-files-atheros-2.6 - 10-9078 -
bridge - 1.0.6-1 -
busybox - 1.4.2-2 -
dnsmasq - 2.39-1 -
dropbear - 0.50-2 -
hostapd - 0.5.7-1 -
hotplug2 - 0.9+r102-2 -
iptables - 1.3.7-1 -
kernel - 2.6.21.5-atheros-1 -
kmod-madwifi - 2.6.21.5+r2568-20070710-atheros-2 -
kmod-ppp - 2.6.21.5-atheros-1 -
kmod-pppoe - 2.6.21.5-atheros-1 -
libgcc - 4.1.2-10 -
libopenssl - 0.9.8e-1 -
mtd - 5 -
ppp - 2.4.3-8 -
ppp-mod-pppoe - 2.4.3-8 -
uclibc - 0.9.28-10 -
udevtrigger - 106-1 -
wireless-tools - 29-1 -
wpa-supplicant - 0.5.7-1 -
zlib - 1.2.3-4 -
Done.

Se i pacchetti che avete sono + o – questi possiamo andare oltre…
Passiamo ora alla configurazione delle interfacce. In primo luogo modifichiamo la network lan

root@OpenWrt:~# vi /etc/config/network

#### LAN configuration
config interface lan
option type bridge
option ifname eth0.0
option proto static
option ipaddr 192.168.1.111
option netmask 255.255.255.0

Poi passiamo alla parte wireless

root@OpenWrt:~# vi /etc/config/wireless

config wifi-device wl0
option type broadcom
option channel 11 # lo stesso canale della wifi di Alice


config wifi-iface
option device wl0
option network lan
option mode ap
option ssid RepeaterWifi # il nome della wifi del repeater

config wifi-iface
option device wl0
option network lan
option mode sta
option ssid Alice-12345678 # il nome della rete wifi da ripetere
option encryption 'psk'
option key 'xxxxxxxxxxxxxxxxxxxxx'

Fatto ciò dovresta avere un bel ripetitore wifi!!