ASUS RT N16 e DD-WRT: Un router SUPER!

7 04 2012
Premessa

Ho da poco acquistato un ASUS RT N16, porte USB, 4 LAN, wifi n … non potevo non sbrasarlo!
Visto che lo userò per casa ho scelto come distro DD-WRT, sia per la faciltà d’uso che per i molteplici pacchetti opzionali già disponibili online.

Come prima cosa procediamo col preparare una memoria di massa per la nostra piccola LinuxBox.

Optware

Per maggiori dettagli su Optware vi rimando qui

Iniziamo col preparare il nostro disco USB (maggiori dettagli) creando le partizioni Linux adeguate.
Inseriamo il nostro disco USB in un PC Linux. Dopo che il S.O. l’avrà riconosciuto verifichiamo il nome del device (nel nostro esempio sarà /dev/sdb) e smontiamolo.
Seguiamo la procedura seguente, da shell:

root@Linux:/fdisk /dev/sdb
Command (m for help): d
Selected partition 1
Command (m for help): p
Disk /dev/sdd: 
[...]
Command (m for help): p
[...]
Command (m for help): n
Command action
  e   extended
  p   primary partition (1-4)
p
Partition number (1-4): 1
First cylinder (1-621, default 1):<ENTER>
Using default value 1
Last cylinder or +size or +sizeM or +sizeK (1-621, default 621): +512M <ENTER>
Command (m for help): n
Command action
  e   extended
  p   primary partition (1-4)
p
Partition number (1-4): 2
First cylinder (197-621, default 197):<ENTER>
Using default value 197
Last cylinder or +size or +sizeM or +sizeK (197-621, default 621): +64M <ENTER>
Command (m for help): n
Command action
  e   extended
  p   primary partition (1-4)
p
Partition number (1-4): 3
First cylinder (197-621, default 197):<ENTER>
Using default value 621
Last cylinder or +size or +sizeM or +sizeK (197-621, default 621): +128M <ENTER>
Command (m for help): n
Command action
  e   extended
  p   primary partition (1-4)
p
Partition number (1-4): 4
First cylinder (197-621, default 197):<ENTER>
Using default value 1
Last cylinder or +size or +sizeM or +sizeK (197-621, default 621): <ENTER>
Command (m for help): t
Partition number (1-4): 2
Hex code (type L to list codes): 82
Changed system type of partition 2 to 82 (Linux swap)
Command (m for help): p
[...]
Command (m for help): w

Infine lanciamo:

mke2fs -m 1 -L Optware /dev/sdb1
mke2fs -m 1 -L Shared /dev/sdb3
mke2fs -m 1 -L Data /dev/sdb4
mkswap /dev/sdb2

USB DRIVE PRONTO!! 🙂

Scarichiamo DD-WRT per il nostro router.
Colleghiamoci all’area download  e cerchiamo l’ultima versione disponibile del firmware.

Io ho provato il tutto con la release svn16758.

Andiamo in

Downloads › others › eko › V24-K26 › svn<xyz>
e scarichiamo il file mini.trx

Apriamo il nostro Router ASUS RT-N16 di pacca e colleghiamoci su una delle porte LAN
Apriamo ‘Internet Explorer’ (SI proprio IE!! – questo è il browser raccomandato!) ed andiamo nella schermata del firmware upgrade.


Da qui carichiamo il file mini ed attendiamo l’upgrade.
Una volta terminato possiamo accedere al router ed inserire le nostre credenziali preferite (ad es: root – pass, ma anche admin – admin se siete coraggiosi!)

Questa versione contiene moltissime funzionalità evolute, ma per godere del vero salto di qualità dovremo passare alla MEGA di DD-wrt.

Scarichiamo il file della stessa release della mini (nel mio caso 16758)
ed installiamolo usando l’interfaccia web di DD
Administration->Firmware Upgrade
Settiamo
After flashing, reset to: Reset
to Default Settings
e ri-accediamo al router sulla classica 192.168.1.1 da webif
Questa versione GRANDE ci permette di fare molte +cose e ci da accesso a funzionalità avanzate. Tra queste troviamo quella di nostro interesse. L’accesso ai servizi USB del router (opzione assente nella ver. mini)

Rendiamo accessibile il disco USB realizzato in precedenza.
Dalla web GUI
Services->USB
abilitiamo: Core USB
support USB 2.0
support USB storage
support Printer Support (optional)
ext2/ext3 File System support – solo per le versioni precedenti alla SVN 15501
FAT File system support solo per le versioni precedenti alla SVN 15501
Automatic Drive Mount
Selezioniamo mount ad /opt dal menu a tendina
Salviamo ed applichiamo le modifiche.
Riavviato il router bisogna farlo uscire su Internet.
Quindi disabilitiamo il Firewall di DDWTR
Andiamo all GUI Web Security->Firewall->SPI Firewall disable
torniamo da shell e lanciamo un ping per vedere se usciamo
Se tutto OK possiamo scaricare optware

wget -O /tmp/prep_optware http://wd.mirmana.com/prep_optware
sh /tmp/prep_optware

ora l’installer inizierà a fare un pò di spesa sul WEB.
Andiamo a farci un caffè e al nostro ritorno troveremo tutto pronto.
Possiamo riavviare il router ed assicurarci che il driver sia montato correttamente, come indicato nell’immagine sotto.

Per dare uno sguardo a cosa abbiamo creato basta fare
service

Troveremo tutti i servizi da utilizzare subito, tra cui Samba, Asterisk, Transmission (un client torrent) …

BUON DIVERTIMENTO!





Una DeLorean Elettrica!? Grande Giove!!

4 10 2010

Ritorno al Futuro

Al decorrere dei 25 anni dall’uscita di una delle pellicole più rivoluzionare ed originali della storia del cinema, qui in Italia ne hanno combinato una bella!

Il 25 ottobre, lo stesso giorno in cui 25 anni fa Doc e Marty iniziarono le loro avventure a spasso nel tempo, una DeLorean DMC -12 inizierà la sua traversata da Milano a Roma.

Ma la particolarità è che il bolide anni 80 sarà in realtà un auto elettrica.

Con l’avvio del progetto E-Mobility, la rete di energy point tanto attesa da ENEL, un team di esperti reclutati direttamente da Wired Italia (in sostanza 2 pazzi/nerd/geniacci) hanno deciso di lanciarsi in questa avventura geek.

Qui tutti i dettagli di questo pazzo/geniale esperimento

P.S.: Doc ma che diavolo è un gigowatt!?!?!?!?





AR.Drone: un quadcopter per iPhone

5 09 2010

Da quando ha volato nei cieli del CCCamp nel 2007 di progetti di quad-copter se ne sono visti molti, ma non pensavo che questo gioiellino geek sarebbe diventato in così breve tempo un giocattolo da gamers incalliti.

Si chiama AR.Drone e per la fine di questo settembre sarà possibile acquistarlo in tutti i GameStop. Si tratta di un quad-copter pilotabile da iPhone/iPad e potrete accalappiarvelo per poco meno di 300 Euro.
Le specifiche tecniche sono di tutto rispetto: 4 motori brushless, struttura in fibra di carbonio, 2 telecamere (frontale e verticale) per lo streaming real time, controllo wifi, accelerometro e giroscopio. Insomma un vero must per gli amanti della tecnologia, magari 30/40enni stufi della solita partita a PES su PS3.

L’ulteriori chicca sta nel fatto, come suggerisce il nome stesso (AR sta infatti per Augmented Reality), scaricando software appositi sarà possibile, oltre a sfruttare la telecamera per controllare il quadcopter in volo libero, visualizzare dei veri e propri  percorsi di guerra, con laser e proiettili che popolano il cortile di casa. Si potrà inoltre  simulare una guerra virtuale tra altri quadcopter cimentandosi in duelli aerei all’ultimo sangue.

Se quindi, la prossima volta che portate il cane al parco per i canonici bisognini, vi vedete sfrecciare sulla testa un Unidentified Flying Object, non gridate subito all’UFO! Potrebbe essere il figlio del vostro vicino che si sta divertendo con il suo nuovo quad-copter.

Scaricando software di scenari, le immagini rilanciate sul nostro telefonino prendono le forme di percorsi di guerra, con mostri e proiettili che popolano il cortile di casa




Gmail Priority Inbox

5 09 2010

Stamattina come al solito vado a controllare la mail e cosa ti trovo che il buo zio G mi ha preparato?
una bella posta prioritaria!!

Seguendo il trend abituale i capoccioni di Google hanno preparato anche un semplice e diretto filmatino esplicativo che rende chiaro tutto il servizio offerto con poche e semplici parole.
L’idea è semplice: aiutare l’utente a leggere prima i messaggi veramente interessanti, portare in secondo piano i restanti ed eventualmente, contrassegnare come “speciali” quelli particolarmente degni di nota.
Il tutto coadiuvato dal potente motore antispam che già fa bene il suo dovere nella gmail tradizionale.

Ovviamente BigG sottolinea che il servizio è ancora in Beta, (anche se con giusto 2 click è possibile aggungere questa feature alla propria casella mail) quindi se il filtro commette un errore può intervenire l’utente in maniera manuale a metterci una pezza.
La cosa grande è che questo filtro, come l’antispam, impara col tempo quindi più viene usato e più è affidabile.

Che dire, lo provo!





OpenWrt su Linksys WRT54G: Universal Repeater

29 09 2009

Quante volte vi siete trovati a girare per casa in cerca del vostro segnale wifi?
Quante volte avreste desiderato abbattere quella maledetta parete di tufo/pietra ottocentesca di casa vostra che riduce drasticamente le probabilità di navigare in wireless per tutta la casa?
Quante volte avete desiderato espandere il vostro wifi oltre i confini delle striminzite antennine del vostro Alice Gate di Telecozz?
Bene ora potete!

Universal Repeater

Bene, tralasciando questa ridicola introduzione e venendo al dunque ho ottenuto un comodo ripetitore di segnale configurando il mio WRT54GL con pochi passaggi.
La situazione in cui ci troviamo è tipo quella riportata in figura.

Ampliare la rete wifi con un repeater

Ampliare la rete wifi con un repeater

Per prima cosa è necessario (se si vuole utilizzare la WPA-PSK impostata di default da Telecom) scaricare i seguenti pacchetti direttamente su OpenWrt.

root@OpenWrt:~# ipkg install wpa-supplicant
root@OpenWrt:~# ipkg install hostapd
root@OpenWrt:~# ipkg install zlib
root@OpenWrt:~# ipkg install libopenssl

Per poter visionare cosa avete sul sistema usate questo

root@OpenWrt:~# ipkg list_installed
base-files-atheros-2.6 - 10-9078 -
bridge - 1.0.6-1 -
busybox - 1.4.2-2 -
dnsmasq - 2.39-1 -
dropbear - 0.50-2 -
hostapd - 0.5.7-1 -
hotplug2 - 0.9+r102-2 -
iptables - 1.3.7-1 -
kernel - 2.6.21.5-atheros-1 -
kmod-madwifi - 2.6.21.5+r2568-20070710-atheros-2 -
kmod-ppp - 2.6.21.5-atheros-1 -
kmod-pppoe - 2.6.21.5-atheros-1 -
libgcc - 4.1.2-10 -
libopenssl - 0.9.8e-1 -
mtd - 5 -
ppp - 2.4.3-8 -
ppp-mod-pppoe - 2.4.3-8 -
uclibc - 0.9.28-10 -
udevtrigger - 106-1 -
wireless-tools - 29-1 -
wpa-supplicant - 0.5.7-1 -
zlib - 1.2.3-4 -
Done.

Se i pacchetti che avete sono + o – questi possiamo andare oltre…
Passiamo ora alla configurazione delle interfacce. In primo luogo modifichiamo la network lan

root@OpenWrt:~# vi /etc/config/network

#### LAN configuration
config interface lan
option type bridge
option ifname eth0.0
option proto static
option ipaddr 192.168.1.111
option netmask 255.255.255.0

Poi passiamo alla parte wireless

root@OpenWrt:~# vi /etc/config/wireless

config wifi-device wl0
option type broadcom
option channel 11 # lo stesso canale della wifi di Alice


config wifi-iface
option device wl0
option network lan
option mode ap
option ssid RepeaterWifi # il nome della wifi del repeater

config wifi-iface
option device wl0
option network lan
option mode sta
option ssid Alice-12345678 # il nome della rete wifi da ripetere
option encryption 'psk'
option key 'xxxxxxxxxxxxxxxxxxxxx'

Fatto ciò dovresta avere un bel ripetitore wifi!!





Wiimote Hack!

21 06 2008

L’hacker è un personaggio che conosce accuratamente il sistema su cui interviene, è in grado di usarlo in un modo diverso dal consueto, ed è in grado di adattarlo alle proprie esigenze, il tutto spinto dalla pura voglia di conoscenza, mista però a tanto sano divertimento e un pizzico di malizia. Questa definizione è una di quelle che più mi piace associare alla parola hacker.

Di riflesso un “hack” può definire un modo per usare un oggetto in modo creativo e divertente.

Johnny Chung Lee questo lo sa di certo ed è riuscito in un hack molto divertente e creativo, anzi direi geniale!

Come ci dimostrano i suoi filmati su You Tube e le esperienze sul suo sito il dottorone cino-americano è riuscito ad usare il wiimote (telecomando/pad della wii) in un modo veramente hack!

Con un wiimote una chiavetta bluetooth e un pò di devozione è possibile ralizzare una lavagna interattiva molto economica, rendere il proprio monitor touch screen, emulare le gesta di John Anderton (il protagonista di Minority Report) interagendo con un software muovendo le sole mani!! Ah inoltre è riuscito a creare un sistema interattivo di head tracking con un paio di occhiali e due led infrarossi!!

Vivamente Consigliato!!