OpenWrt su Linksys WRT54G: Universal Repeater

29 09 2009

Quante volte vi siete trovati a girare per casa in cerca del vostro segnale wifi?
Quante volte avreste desiderato abbattere quella maledetta parete di tufo/pietra ottocentesca di casa vostra che riduce drasticamente le probabilità di navigare in wireless per tutta la casa?
Quante volte avete desiderato espandere il vostro wifi oltre i confini delle striminzite antennine del vostro Alice Gate di Telecozz?
Bene ora potete!

Universal Repeater

Bene, tralasciando questa ridicola introduzione e venendo al dunque ho ottenuto un comodo ripetitore di segnale configurando il mio WRT54GL con pochi passaggi.
La situazione in cui ci troviamo è tipo quella riportata in figura.

Ampliare la rete wifi con un repeater

Ampliare la rete wifi con un repeater

Per prima cosa è necessario (se si vuole utilizzare la WPA-PSK impostata di default da Telecom) scaricare i seguenti pacchetti direttamente su OpenWrt.

root@OpenWrt:~# ipkg install wpa-supplicant
root@OpenWrt:~# ipkg install hostapd
root@OpenWrt:~# ipkg install zlib
root@OpenWrt:~# ipkg install libopenssl

Per poter visionare cosa avete sul sistema usate questo

root@OpenWrt:~# ipkg list_installed
base-files-atheros-2.6 - 10-9078 -
bridge - 1.0.6-1 -
busybox - 1.4.2-2 -
dnsmasq - 2.39-1 -
dropbear - 0.50-2 -
hostapd - 0.5.7-1 -
hotplug2 - 0.9+r102-2 -
iptables - 1.3.7-1 -
kernel - 2.6.21.5-atheros-1 -
kmod-madwifi - 2.6.21.5+r2568-20070710-atheros-2 -
kmod-ppp - 2.6.21.5-atheros-1 -
kmod-pppoe - 2.6.21.5-atheros-1 -
libgcc - 4.1.2-10 -
libopenssl - 0.9.8e-1 -
mtd - 5 -
ppp - 2.4.3-8 -
ppp-mod-pppoe - 2.4.3-8 -
uclibc - 0.9.28-10 -
udevtrigger - 106-1 -
wireless-tools - 29-1 -
wpa-supplicant - 0.5.7-1 -
zlib - 1.2.3-4 -
Done.

Se i pacchetti che avete sono + o – questi possiamo andare oltre…
Passiamo ora alla configurazione delle interfacce. In primo luogo modifichiamo la network lan

root@OpenWrt:~# vi /etc/config/network

#### LAN configuration
config interface lan
option type bridge
option ifname eth0.0
option proto static
option ipaddr 192.168.1.111
option netmask 255.255.255.0

Poi passiamo alla parte wireless

root@OpenWrt:~# vi /etc/config/wireless

config wifi-device wl0
option type broadcom
option channel 11 # lo stesso canale della wifi di Alice


config wifi-iface
option device wl0
option network lan
option mode ap
option ssid RepeaterWifi # il nome della wifi del repeater

config wifi-iface
option device wl0
option network lan
option mode sta
option ssid Alice-12345678 # il nome della rete wifi da ripetere
option encryption 'psk'
option key 'xxxxxxxxxxxxxxxxxxxxx'

Fatto ciò dovresta avere un bel ripetitore wifi!!

Annunci

Azioni

Information

8 responses

19 10 2009
Paolo

Ciao!

Ho provato le tue indicazioni, ma non riesco a far funzionare l’amba-aradan..

Ci sono alcune cose che non mi tornano :

1) parli di wrt54g (broadcom) ma cerchi i pacchetti atheros (?)
2) che ci fai con hostpad sul wrt54g? non è un driver per altre interfacce?
3) invece le iface sono corrette per broadcom wl0
4) comunque io non riesco neanche ad installare libopenssl, in quanto mi dice che non c’è spazio (ed è un wrt54gl, quindi con buona memoria)
5) ho provato a seguire le indicazioni senza installazione dei pacchetti, ma non riesco neanche a fare da repeater di una rete aperta.
6) network
config ‘switch’ ‘eth0’
option ‘vlan0’ ‘0 1 2 3 5*’
option ‘vlan1’ ‘4 5’

config ‘interface’ ‘loopback’
option ‘ifname’ ‘lo’
option ‘proto’ ‘static’
option ‘ipaddr’ ‘127.0.0.1’
option ‘netmask’ ‘255.0.0.0’

config ‘interface’ ‘lan’
option ‘type’ ‘bridge’
option ‘ifname’ ‘eth0.0’
option ‘proto’ ‘static’
option ‘netmask’ ‘255.255.255.0’
option ‘ipaddr’ ‘192.168.3.240’
option ‘gateway’ ‘192.168.3.1’
option ‘dns’ ‘192.168.3.1’

7) wireless
config ‘wifi-device’ ‘wl0’
option ‘type’ ‘broadcom’
option ‘channel’ ‘9’
option ‘disabled’ ‘0’
option ‘country’ ‘it’

config ‘wifi-iface’
option ‘device’ ‘wl0’
option ‘encryption’ ‘psk’
option ‘key’ ‘tantomontamontatantoisabelcomofernando’
option ‘ssid’ ‘dlink’
option ‘network’ ‘lan’
option ‘mode’ ‘sta’

config ‘wifi-iface’
option ‘device’ ‘wl0’
option ‘mode’ ‘ap’
option ‘ssid’ ‘Bruno’
option ‘network’ ‘lan’
option ‘encryption’ ‘psk’
option ‘key’ ‘tantomontamontatantoisabelcomofernando’

Io ho provato con queste configurazioni e non riesco – hai idee su come sbloccare la cosa?
gRAZIE,

Paolo

19 10 2009
alcolistaanonimo

Su questo hai ragione ho messo il listato dei pkg installati su una fonera…grazie x avermi segnalato la svista porrò subito rimedio…cmq la cosa è similare anche per il wrt54gl…
in ogni caso mi sembra stano ke hai già saturato la memoria, rifai un listato dei tuoi pacchetti installati e vedi se puoi eliminare qualcosa di superfluo con ipkg remove . Per controllare il livello di occupazione della tua memoria puoi sempre ricorrere ad un df -h
Ma che versione di openwrt usi? Io ho testato il tutto con una kamikaze 7.09
PS: la tua conf mi sembra vada bene ma senza il wpa-supplicant nn funge!

20 10 2009
Paolo

Ho reinstallato e messo wpa-supplicant e hostpad_mini, che sembrano essere i pacchetti necessari per ap e client WPA, almeno per vecchie versioni (http://wiki.openwrt.org/oldwiki/openwrtdocs/kamikazeconfiguration).
Ho anche eliminato il DHCP e settato dnsmasq per funzionare con un altro dhcp nella rete, ma non da segni di vita.
Openwrt è una 8.09.01.
Openwrt è veramente privo di una documentazione seria…

14 03 2010
paride

Ciao,
ho letto questa pagina, e vorrei porti una domanda, visto che in openwrt, non mi ci raccapezzo. Se io volessi fare praticamente la stessa cosa, tranne che per l’ultimo punto (repeater –> notebook), che dovrebbe essere via cavo, cosa debbo modificare?
Avevo pensato al wds, ma praticamente se i router non sono uguali sono solo casini e NON funziona mai, e difatti non va.
Il router principale e’ una alice, riflashato con il firmware usr9108 modificato, quindi GNU/Linux. Il repeater, e’ una fonera 2100 con l’ultimo openwrt (flashato ieri sera).
Quindi vorrei usare la fonera collegata con il cavo di rete in modo che mi faccia da client per l’altro router che usa il wpa-psk.

17 04 2010
alcolistaanonimo

Il tutto dovrebbe funzionare regolarmente senza fare alcuna modifica. Dovresti comunque trovarti il repeater sullo stesso indirizzo in quanto risulta bridge-ato. (scusami il termine)

17 04 2010
Paolo

Ciao!

Se vuoi un repeater bridge (repeater con indirizzi ip dei clienti del repeater nella stessa rete del router principale, ad esempio 192.168.1.n) l’unico firmware a mia conoscenza che funziona senza storie è dd-wrt

http://www.dd-wrt.com/wiki/index.php/Repeater_Bridge

Se puoi accontentarti di un repeater (indirizzi ip dei clienti del repeater su rete diversa dalla rete principale, ad esempio rete principale 192.168.1.n e rete distribuita dal repeater 192.168.2.m) ero alla fine riuscito a far funzionare anche openwrt, ma non ricordo più come.
Ai soli fini pratici dell’uso come repeater non posso che consigliare dd-wrt.
Mi sento di consigliare openwrt solo ad un utente esperto che voglia un pò trafficare, oltre che col repeater, con applicazioni poco usali (a me serviva per l’ipv6, per essere raggiungibile fuori dalla rete di Fastweb).

Paolo

17 04 2010
alcolistaanonimo

Ho provato dd-wrt un pò di tempo fa ed effettivamente risultava molto semplice creare un repeater direttamente tramite interfaccia gui. Cmq openwrt mi sembra un gran progetto, molto completo e con cui sicuramente puoi fare cose molto interessanti (v. mesh). Ti consiglio di approfondirlo. Per quanto riguarda l’universal repeater mi riprometto di verificare il tutto quanto prima …con una bella fonera+ 🙂

23 04 2010
alcolistaanonimo

La Fonera non può fare da bridge! Al contrario il Wrt54 lo può fare avendo dei driver proprietari (wl.o driver), insomma è fuori standard
Per ulteriori informnazioni http://wiki.openwrt.org/doc/recipes/bridgedclient
Per info su come realizzare un repeater con la fonera potete consultare
http://wiki.ninux.org/FoneraAsRepeaterHowTo
a cura dei super-competenti amici di ninux.org

Rispondi

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...




%d blogger hanno fatto clic su Mi Piace per questo: